import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s|^)(?:[a-zA-Z_$]+[\\w$]*)(?:\\.[a-zA-Z_$]+[\\w$]*)+(?:\\s|$)";
final String string = "this is a long string with a property path inside of it. someobject.somekey.somechildkey.somegrandchildkey and then a shorter.one and blah one.that.1should.not blah";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}