re = /(?:\s|^)(?:[a-zA-Z_$]+[\w$]*)(?:\.[a-zA-Z_$]+[\w$]*)+(?:\s|$)/
str = 'this is a long string with a property path inside of it. someobject.somekey.somechildkey.somegrandchildkey and then a shorter.one and blah one.that.1should.not blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end