const regex = /(?:\s|^)(?:[a-zA-Z_$]+[\w$]*)(?:\.[a-zA-Z_$]+[\w$]*)+(?:\s|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s|^)(?:[a-zA-Z_$]+[\\w$]*)(?:\\.[a-zA-Z_$]+[\\w$]*)+(?:\\s|$)', 'g')
const str = `this is a long string with a property path inside of it. someobject.somekey.somechildkey.somegrandchildkey and then a shorter.one and blah one.that.1should.not blah`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}