$re = '/([а-яА-Я.“”]+\s?)+/m';
$str = '2 Цвет черный.
- Цвет черный.
- Рукав покроя “реглан”.
Цвет черный.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);