// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([а-яА-Я.“”]+\s?)+").unwrap();
let string = "2 Цвет черный.
- Цвет черный.
- Рукав покроя “реглан”.
Цвет черный.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}