using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(spec|test)\.js$";
string input = @"test-test-file.js
testFileSpec.js
some-file-test.js";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}