re = /(spec|test)\.js$/im
str = 'test-test-file.js
testFileSpec.js
some-file-test.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end