#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
" (?!<[^<\s]*<)" & @CRLF & _
" (?:" & @CRLF & _
" [<>]?" & @CRLF & _
" [a-zA-Z]+" & @CRLF & _
" (?:[-+]\d+(?:\.\d+)?(?:em)?)?" & @CRLF & _
" )" & @CRLF & _
" (?:" & @CRLF & _
" <" & @CRLF & _
" [a-zA-Z]+" & @CRLF & _
" (?:[-+]\d+(?:\.\d+)?(?:em)?)?" & @CRLF & _
" )?" & @CRLF & _
"$"
Local $sString = "<alpha+10em" & @CRLF & _
">alpha+1.5em" & @CRLF & _
"<alpha+1.5em" & @CRLF & _
">alpha-1.5em" & @CRLF & _
">alpha-1.5em" & @CRLF & _
"alpha-50em<delta-100em" & @CRLF & _
"alpha-50em<delta+100em" & @CRLF & _
">alpha-50em<delta+100em" & @CRLF & _
"<alpha<bravo" & @CRLF & _
">alpha<bravo" & @CRLF & _
"alpha+100px"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")