re = /^
(?!<[^<\s]*<)
(?:
[<>]?
[a-zA-Z]+
(?:[-+]\d+(?:\.\d+)?(?:em)?)?
)
(?:
<
[a-zA-Z]+
(?:[-+]\d+(?:\.\d+)?(?:em)?)?
)?
$/mx
str = '<alpha+10em
>alpha+1.5em
<alpha+1.5em
>alpha-1.5em
>alpha-1.5em
alpha-50em<delta-100em
alpha-50em<delta+100em
>alpha-50em<delta+100em
<alpha<bravo
>alpha<bravo
alpha+100px'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end