// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^
(?!<[^<\s]*<)
(?:
[<>]?
[a-zA-Z]+
(?:[-+]\d+(?:\.\d+)?(?:em)?)?
)
(?:
<
[a-zA-Z]+
(?:[-+]\d+(?:\.\d+)?(?:em)?)?
)?
$").unwrap();
let string = "<alpha+10em
>alpha+1.5em
<alpha+1.5em
>alpha-1.5em
>alpha-1.5em
alpha-50em<delta-100em
alpha-50em<delta+100em
>alpha-50em<delta+100em
<alpha<bravo
>alpha<bravo
alpha+100px";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}