$re = '~^(?!http://)(?!www\.).+$~mi';
$str = 'example.com/example
example.com
http://example.com/example
http://www.example.com/example
www.example.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);