import re
regex = re.compile(r"^(?!http://)(?!www\.).+$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("example.com/example\n"
"example.com\n"
"http://example.com/example\n"
"http://www.example.com/example\n"
"www.example.com\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")