re = /^(?!http:\/\/)(?!www\.).+$/mi
str = 'example.com/example
example.com
http://example.com/example
http://www.example.com/example
www.example.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end