const regex = /.*(?:youtu.be\/|v\/|u\/\w\/|embed\/|watch\?v=)([^#\&\?]*).*/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(?:youtu.be\\\/|v\\\/|u\\\/\\w\\\/|embed\\\/|watch\\?v=)([^#\\&\\?]*).*', 'gi')
const str = `<iframe width="560" height="315" src="https://www.youtube.com/embed/123?list=PLVlyYfbClWxRpOSJvalIUTBxoqkrzowzI" frameborder="0" allowfullscreen></iframe>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}