$re = '/.*(?:youtu.be\/|v\/|u\/\w\/|embed\/|watch\?v=)([^#\&\?]*).*/i';
$str = '<iframe width="560" height="315" src="https://www.youtube.com/embed/123?list=PLVlyYfbClWxRpOSJvalIUTBxoqkrzowzI" frameborder="0" allowfullscreen></iframe>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);