#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<id>(.+?)<\/id>|<name>(.+?)<\/name>|<time>(.+?)<\/time>|<line>(.+?)<\/line>|<timeMin>(.+?)<\/timeMin>"
Local $sString = "<?xml version="1.0" encoding="utf-8"?>" & @CRLF & _
"<ArrayOfPolling xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">" & @CRLF & _
" <Polling>" & @CRLF & _
" <id>1494</id>" & @CRLF & _
" <name>Street xyz</name>" & @CRLF & _
" <time>14.08</time>" & @CRLF & _
" <line>AB2</line>" & @CRLF & _
" <timeMin>5</timeMin>" & @CRLF & _
" </Polling>" & @CRLF & _
" <Polling>" & @CRLF & _
" <id>1494</id>" & @CRLF & _
" <name>Street xyz</name>" & @CRLF & _
" <time>14.10</time>" & @CRLF & _
" <line>140</line>" & @CRLF & _
" <timeMin>7</timeMin>" & @CRLF & _
" </Polling>" & @CRLF & _
" <Polling>" & @CRLF & _
" <id>1494</id>" & @CRLF & _
" <name>Street xyz</name>" & @CRLF & _
" <time>14.12</time>" & @CRLF & _
" <line>AB2</line>" & @CRLF & _
" <timeMin>9</timeMin>" & @CRLF & _
" </Polling>" & @CRLF & _
" <Polling>" & @CRLF & _
" <id>1494</id>" & @CRLF & _
" <name>Street xyz</name>" & @CRLF & _
" <time>14.15</time>" & @CRLF & _
" <line>140</line>" & @CRLF & _
" <timeMin>12</timeMin>" & @CRLF & _
" </Polling>" & @CRLF & _
"</ArrayOfPolling>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")