import re
regex = re.compile(r"<id>(.+?)<\/id>|<name>(.+?)<\/name>|<time>(.+?)<\/time>|<line>(.+?)<\/line>|<timeMin>(.+?)<\/timeMin>")
test_str = ("<?xml version=\"1.0\" encoding=\"utf-8\"?>\n"
"<ArrayOfPolling xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\">\n"
" <Polling>\n"
" <id>1494</id>\n"
" <name>Street xyz</name>\n"
" <time>14.08</time>\n"
" <line>AB2</line>\n"
" <timeMin>5</timeMin>\n"
" </Polling>\n"
" <Polling>\n"
" <id>1494</id>\n"
" <name>Street xyz</name>\n"
" <time>14.10</time>\n"
" <line>140</line>\n"
" <timeMin>7</timeMin>\n"
" </Polling>\n"
" <Polling>\n"
" <id>1494</id>\n"
" <name>Street xyz</name>\n"
" <time>14.12</time>\n"
" <line>AB2</line>\n"
" <timeMin>9</timeMin>\n"
" </Polling>\n"
" <Polling>\n"
" <id>1494</id>\n"
" <name>Street xyz</name>\n"
" <time>14.15</time>\n"
" <line>140</line>\n"
" <timeMin>12</timeMin>\n"
" </Polling>\n"
"</ArrayOfPolling>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")