import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<id>(.+?)<\\/id>|<name>(.+?)<\\/name>|<time>(.+?)<\\/time>|<line>(.+?)<\\/line>|<timeMin>(.+?)<\\/timeMin>";
final String string = "<?xml version=\"1.0\" encoding=\"utf-8\"?>\n"
+ "<ArrayOfPolling xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\">\n"
+ " <Polling>\n"
+ " <id>1494</id>\n"
+ " <name>Street xyz</name>\n"
+ " <time>14.08</time>\n"
+ " <line>AB2</line>\n"
+ " <timeMin>5</timeMin>\n"
+ " </Polling>\n"
+ " <Polling>\n"
+ " <id>1494</id>\n"
+ " <name>Street xyz</name>\n"
+ " <time>14.10</time>\n"
+ " <line>140</line>\n"
+ " <timeMin>7</timeMin>\n"
+ " </Polling>\n"
+ " <Polling>\n"
+ " <id>1494</id>\n"
+ " <name>Street xyz</name>\n"
+ " <time>14.12</time>\n"
+ " <line>AB2</line>\n"
+ " <timeMin>9</timeMin>\n"
+ " </Polling>\n"
+ " <Polling>\n"
+ " <id>1494</id>\n"
+ " <name>Street xyz</name>\n"
+ " <time>14.15</time>\n"
+ " <line>140</line>\n"
+ " <timeMin>12</timeMin>\n"
+ " </Polling>\n"
+ "</ArrayOfPolling>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}