package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[A-Z]{2}[ -]?[0-9]{1,2}[ -]?(?: [A-Z])?[ -]?(?: [A-Z]*)?[ -]?[0-9]{4}`)
var str = `ka 03 c ml 1017`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}