$re = '/[A-Z]{2}[ -]?[0-9]{1,2}[ -]?(?: [A-Z])?[ -]?(?: [A-Z]*)?[ -]?[0-9]{4}/i';
$str = 'ka 03 c ml 1017';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);