re = /[A-Z]{2}[ -]?[0-9]{1,2}[ -]?(?: [A-Z])?[ -]?(?: [A-Z]*)?[ -]?[0-9]{4}/i
str = 'ka 03 c ml 1017'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end