#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?!(?<=@#%)(?=2@#%))2"
Local $sString = "2" & @CRLF & _
"12322" & @CRLF & _
"asdad2" & @CRLF & _
"@#%2" & @CRLF & _
"2@#%" & @CRLF & _
"@#%2@#%" & @CRLF & _
"2@#%2@#%2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")