re = /(?!(?<=@#%)(?=2@#%))2/mi
str = '2
12322
asdad2
@#%2
2@#%
@#%2@#%
2@#%2@#%2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end