import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!(?<=@#%)(?=2@#%))2";
final String string = "2\n"
+ "12322\n"
+ "asdad2\n"
+ "@#%2\n"
+ "2@#%\n"
+ "@#%2@#%\n"
+ "2@#%2@#%2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}