#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)&(?!(?:#[0-9]+|[a-z]+);)"
Local $sString = "Peter & Mary" & @CRLF & _
"B&B" & @CRLF & _
"He & I went;" & @CRLF & _
"&" & @CRLF & _
"p" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)