re = /&(?!(?:#[0-9]+|[a-z]+);)/m
str = 'Peter & Mary
B&B
He & I went;
&
p
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result