using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"&(?!(?:#[0-9]+|[a-z]+);)";
string substitution = @"";
string input = @"Peter & Mary
B&B
He & I went;
&
p
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}