#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "os\s*= (.*)"
Local $sString = "--- p0f 3.08b by Michal Zalewski <lcamtuf@coredump.cx> ---" & @CRLF & _
"" & @CRLF & _
"[+] Closed 3 file descriptors." & @CRLF & _
"[+] Loaded 324 signatures from '/etc/p0f/p0f.fp'." & @CRLF & _
"[+] Will read pcap data from file 'temp.pcap'." & @CRLF & _
"[+] Default packet filtering configured [+VLAN]." & @CRLF & _
"[+] Processing capture data." & @CRLF & _
"" & @CRLF & _
".-[ 10.0.7.20/44964 -> 216.58.208.37/443 (syn) ]-" & @CRLF & _
"|" & @CRLF & _
"| client = 10.0.7.20/44964" & @CRLF & _
"| os = Linux 3.11 and newer" & @CRLF & _
"| dist = 0" & @CRLF & _
"| params = none" & @CRLF & _
"| raw_sig = 4:64+0:0:1460:mss*20,7:mss,sok,ts,nop,ws:df,id+:0" & @CRLF & _
"|" & @CRLF & _
"`----" & @CRLF & _
"" & @CRLF & _
".-[ 10.0.7.20/44964 -> 216.58.208.37/443 (mtu) ]-" & @CRLF & _
"|" & @CRLF & _
"| client = 10.0.7.20/44964" & @CRLF & _
"| link = Ethernet or modem" & @CRLF & _
"| raw_mtu = 1500" & @CRLF & _
"|" & @CRLF & _
"`----" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")