using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"os\s*= (.*)";
string input = @"--- p0f 3.08b by Michal Zalewski <lcamtuf@coredump.cx> ---
[+] Closed 3 file descriptors.
[+] Loaded 324 signatures from '/etc/p0f/p0f.fp'.
[+] Will read pcap data from file 'temp.pcap'.
[+] Default packet filtering configured [+VLAN].
[+] Processing capture data.
.-[ 10.0.7.20/44964 -> 216.58.208.37/443 (syn) ]-
|
| client = 10.0.7.20/44964
| os = Linux 3.11 and newer
| dist = 0
| params = none
| raw_sig = 4:64+0:0:1460:mss*20,7:mss,sok,ts,nop,ws:df,id+:0
|
`----
.-[ 10.0.7.20/44964 -> 216.58.208.37/443 (mtu) ]-
|
| client = 10.0.7.20/44964
| link = Ethernet or modem
| raw_mtu = 1500
|
`----
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}