# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"os\s*= (.*)"
test_str = ("--- p0f 3.08b by Michal Zalewski <lcamtuf@coredump.cx> ---\n\n"
"[+] Closed 3 file descriptors.\n"
"[+] Loaded 324 signatures from '/etc/p0f/p0f.fp'.\n"
"[+] Will read pcap data from file 'temp.pcap'.\n"
"[+] Default packet filtering configured [+VLAN].\n"
"[+] Processing capture data.\n\n"
".-[ 10.0.7.20/44964 -> 216.58.208.37/443 (syn) ]-\n"
"|\n"
"| client = 10.0.7.20/44964\n"
"| os = Linux 3.11 and newer\n"
"| dist = 0\n"
"| params = none\n"
"| raw_sig = 4:64+0:0:1460:mss*20,7:mss,sok,ts,nop,ws:df,id+:0\n"
"|\n"
"`----\n\n"
".-[ 10.0.7.20/44964 -> 216.58.208.37/443 (mtu) ]-\n"
"|\n"
"| client = 10.0.7.20/44964\n"
"| link = Ethernet or modem\n"
"| raw_mtu = 1500\n"
"|\n"
"`----\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.