package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-zA-Z0-9]=)|(\n\s*\{)|(\(\s)|(\s\))|(\s,)|(\n\s*\{)|(\t)|(\)\{)|(.{81,})|([a-zA-Z0-9][&|\+\-\*\/%]+[a-zA-Z0-9])|(class [a-z])|(class .*_)|( ;)|(==[a-zA-Z0-9])|([a-zA-Z0-9].=[a-zA-Z0-9])`)
var str = `Any "matches" here indicate a possible style error.
Please note that this is not 100% perfect (although we tried our best!)
This may not catch everything, and may incorrectly catch others.
If you believe there is an incorrect match, let us know
on the form when you submit your document.
Please ignore any matches within your comments or string literals.
(i.e. you can break "coding style" in a comment)
Thank you!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}