import Foundation
let pattern = #"([a-zA-Z0-9]=)|(\n\s*\{)|(\(\s)|(\s\))|(\s,)|(\n\s*\{)|(\t)|(\)\{)|(.{81,})|([a-zA-Z0-9][&|\+\-\*\/%]+[a-zA-Z0-9])|(class [a-z])|(class .*_)|( ;)|(==[a-zA-Z0-9])|([a-zA-Z0-9].=[a-zA-Z0-9])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Any "matches" here indicate a possible style error.
Please note that this is not 100% perfect (although we tried our best!)
This may not catch everything, and may incorrectly catch others.
If you believe there is an incorrect match, let us know
on the form when you submit your document.
Please ignore any matches within your comments or string literals.
(i.e. you can break "coding style" in a comment)
Thank you!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)