import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z0-9]=)|(\\n\\s*\\{)|(\\(\\s)|(\\s\\))|(\\s,)|(\\n\\s*\\{)|(\\t)|(\\)\\{)|(.{81,})|([a-zA-Z0-9][&|\\+\\-\\*\\/%]+[a-zA-Z0-9])|(class [a-z])|(class .*_)|( ;)|(==[a-zA-Z0-9])|([a-zA-Z0-9].=[a-zA-Z0-9])";
final String string = "Any \"matches\" here indicate a possible style error.\n\n"
+ "Please note that this is not 100% perfect (although we tried our best!)\n\n"
+ "This may not catch everything, and may incorrectly catch others.\n"
+ "If you believe there is an incorrect match, let us know\n"
+ "on the form when you submit your document.\n\n"
+ "Please ignore any matches within your comments or string literals.\n"
+ "(i.e. you can break \"coding style\" in a comment)\n\n"
+ "Thank you!";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}