using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:([[:lower:]]{3,6}-)|([[:lower:]]{3,6} ?))\d{1,3}$";
string input = @"abc 1
Abc 2
abc-123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}