$re = '/^(?:([[:lower:]]{3,6}-)|([[:lower:]]{3,6} ?))\d{1,3}$/m';
$str = 'abc 1
Abc 2
abc-123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);