re = /^(?:([[:lower:]]{3,6}-)|([[:lower:]]{3,6} ?))\d{1,3}$/m
str = 'abc 1
Abc 2
abc-123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end