using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-ZÀÁÂÄÆÇÈÉÊËÌÍÎÏÒÓÔÖŒÙÚÛÜ][a-zàáâäæçèéêëìíîïòóôöœùúûü]+(-[A-ZÀÁÂÄÆÇÈÉÊËÌÍÎÏÒÓÔÖŒÙÚÛÜ][a-zàáâäæçèéêëìíîïòóôöœùúûü]+)*$";
string input = @"Jean-François";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}