$re = '/^[A-ZÀÁÂÄÆÇÈÉÊËÌÍÎÏÒÓÔÖŒÙÚÛÜ][a-zàáâäæçèéêëìíîïòóôöœùúûü]+(-[A-ZÀÁÂÄÆÇÈÉÊËÌÍÎÏÒÓÔÖŒÙÚÛÜ][a-zàáâäæçèéêëìíîïòóôöœùúûü]+)*$/';
$str = 'Jean-François';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);