package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[A-ZÀÁÂÄÆÇÈÉÊËÌÍÎÏÒÓÔÖŒÙÚÛÜ][a-zàáâäæçèéêëìíîïòóôöœùúûü]+(-[A-ZÀÁÂÄÆÇÈÉÊËÌÍÎÏÒÓÔÖŒÙÚÛÜ][a-zàáâäæçèéêëìíîïòóôöœùúûü]+)*$`)
var str = `Jean-François`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}