using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*[-_]$)[^-_\n].*";
string input = @"sdq
lorem ipsum
abc_def
harry-_potter
fg_
_asq
_dqw-
-asq-sq";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}