$re = '/^(?!.*[-_]$)[^-_\n].*/m';
$str = 'sdq
lorem ipsum
abc_def
harry-_potter
fg_
_asq
_dqw-
-asq-sq';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);