const regex = /^(?!.*[-_]$)[^-_\n].*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*[-_]$)[^-_\\n].*', 'gm')
const str = `sdq
lorem ipsum
abc_def
harry-_potter
fg_
_asq
_dqw-
-asq-sq`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}