import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9A-Za-z_-]+(:[0-9A-Za-z_-]+)?(,?[0-9A-Za-z_-]+(:[0-9A-Za-z_-]+)?)*$";
final String string = "123:123:123\n"
+ "123,123,1234\n"
+ "a23,12d3,1c234\n"
+ "a2_3,1_2d3,1c_234\n"
+ "a2_-3,1_2-d3,1c_2-34\n\n"
+ "123|123|5353\n"
+ "123 123 1234 \n"
+ "hello again jgjg\n"
+ "jgjgj:jgjg:jgjgj\n"
+ "j_gjgj:jg-jg:jg_jgj\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}