use strict;
my $str = '123:123:123
123,123,1234
a23,12d3,1c234
a2_3,1_2d3,1c_234
a2_-3,1_2-d3,1c_2-34
123|123|5353
123 123 1234
hello again jgjg
jgjgj:jgjg:jgjgj
j_gjgj:jg-jg:jg_jgj
';
my $regex = qr/^[0-9A-Za-z_-]+(:[0-9A-Za-z_-]+)?(,?[0-9A-Za-z_-]+(:[0-9A-Za-z_-]+)?)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}