$re = '/^[0-9A-Za-z_-]+(:[0-9A-Za-z_-]+)?(,?[0-9A-Za-z_-]+(:[0-9A-Za-z_-]+)?)*$/m';
$str = '123:123:123
123,123,1234
a23,12d3,1c234
a2_3,1_2d3,1c_234
a2_-3,1_2-d3,1c_2-34
123|123|5353
123 123 1234 
hello again jgjg
jgjgj:jgjg:jgjgj
j_gjgj:jg-jg:jg_jgj
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);