use strict;
my $str = 'GIVEN:
<div>
<span class=\'customer\' id=\'phone$0\'>Home</span>
<br/>
<span class=\'customer\' id=\'phone$1\'>Business</span>
<br/>
<span class=\'customer\' id=\'phone$2\'>Mobile</span>
</div>
DESIRED:
<span class=\'customer NewClass\' id=\'phone$1\'>Organization</span>
';
my $regex = qr/(<span class='customer)(' id='phone\$1[^>]*>)([^<]+)/p;
my $subst = '$1 NewClass$2Organization';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";