$re = '/(<span class=\'customer)(\' id=\'phone\$1[^>]*>)([^<]+)/';
$str = 'GIVEN:
<div>
<span class=\'customer\' id=\'phone$0\'>Home</span>
<br/>
<span class=\'customer\' id=\'phone$1\'>Business</span>
<br/>
<span class=\'customer\' id=\'phone$2\'>Mobile</span>
</div>
DESIRED:
<span class=\'customer NewClass\' id=\'phone$1\'>Organization</span>
';
$subst = "$1 NewClass$2Organization";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;