#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=# v.\n\n)(.|\n)*(?=\n(?:#.*?|$))"
Local $sString = "#### v2" & @CRLF & _
"" & @CRLF & _
"START MATCH" & @CRLF & _
"" & @CRLF & _
"Text explaning things and stuff." & @CRLF & _
"This has to be matched." & @CRLF & _
"" & @CRLF & _
"END MATCH" & @CRLF & _
"" & @CRLF & _
"#### v1" & @CRLF & _
"" & @CRLF & _
"Do not match this part (or anything" & @CRLF & _
"below "END MATCH" part)." & @CRLF & _
"" & @CRLF & _
"#### v0" & @CRLF & _
"" & @CRLF & _
"Do not match this either." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")