import Foundation
let pattern = ##"(?<=# v.\n\n)(.|\n)*(?=\n(?:#.*?|$))"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #####"""
#### v2
START MATCH
Text explaning things and stuff.
This has to be matched.
END MATCH
#### v1
Do not match this part (or anything
below "END MATCH" part).
#### v0
Do not match this either.
"""#####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}