const regex = /(?<=# v.\n\n)(.|\n)*(?=\n(?:#.*?|$))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=# v.\\n\\n)(.|\\n)*(?=\\n(?:#.*?|$))', '')
const str = `#### v2
START MATCH
Text explaning things and stuff.
This has to be matched.
END MATCH
#### v1
Do not match this part (or anything
below "END MATCH" part).
#### v0
Do not match this either.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}